Topic-icon [solved] JEvents Issues

  • daduts
  • daduts's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
06 Dec 2016 04:06 - 07 Dec 2016 09:56 #36032 by daduts
[solved] JEvents Issues was created by daduts
Greetings,

I'm working on using Geommunity on a JEvents site and have a couple issues and a bug report.....

1. I'd like to use JEvents Managed Locations on this site. I see your JEvents for Geommunity plugin has a JEvents Locations mode. I have tried that mode with the JEvents Geocoder plugin both enabled and disabled. In neither case was I able to get a marker to appear on my Geommunity map. Can you give me some instructions on how to get the JEvents Locations mode working ?

2. I've got a bunch of JEvents Categories listed. In the Category Filter box on my map, they appear in order of category id. I'd like to get them to appear alphabetically. (see attachment).

A bug.....

Prior to loading JEvents Locations, I had the Geocoder plugin initially throwing an https Google error. I was able to fix it by changing the google url in line 83 of jevgeocoder.php to https.

Thank you for your attention,

Dave
Attachments:
Last edit: 07 Dec 2016 09:56 by nordmograph.

Please Log in or Create an account to join the conversation.

More
06 Dec 2016 09:55 #36033 by nordmograph
Replied by nordmograph on topic [solved] JEvents Issues
Hello Dave,

I updated plg_geommunity_jevents for the category filter's category ordering.
It's now set to Category Title Ascending (alphabetic)

I also updated the Geocoder for the missing s in https.

For the missing markers.
Check these points:
- Make sure your events have a significant postal address set
- The Geocoder is supposed to process onAfterSave event. It has a debug mode supposed to show Geocoding query result. Ena ble it and let me know what it shows
- Check in phpmyadmin if the Geocder assigns coordinates to the saved/edited event.
- Check if the marker search on the map works for any event
- Check the map browser console for any error message or let me see it.

Hope it helps. Let me know.

- Need help? Post the URL of the related page (eventualy as confidential info), it will help solve your issue faster.
- An error, notice or warning? report the exact message including the line number
- If you get a white page , enable error reporting and / or check your server error logs.

Please Log in or Create an account to join the conversation.

  • daduts
  • daduts's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
06 Dec 2016 18:22 - 06 Dec 2016 21:11 #36036 by daduts
Replied by daduts on topic [solved] JEvents Issues
Hey Adrien,

Thanks for the quick fix....the alphabetical ordering worked nicely.

I've played around with it a bit and the markers now seem to be working properly.

I don't think the site liked editing old events that were entered in Default mode and then edited in Locations mode.

Not an issue for me as this is a new site.

: D
Last edit: 06 Dec 2016 21:11 by daduts.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum
Disclaimer: Nordmograph is not affiliated with or endorsed by The Joomla! Project™. Any products and services provided through this site are not supported or warrantied by The Joomla! Project or Open Source Matters, Inc. Use of the Joomla!® name, symbol, logo and related trademarks is permitted under a limited license granted by Open Source Matters, Inc.
Copyright © 2020 Nordmograph - Joomla extensions. All Rights Reserved.
Joomla! is Free Software released under the GNU General Public License.
Browser of the future